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Cilj vežbe je upoznavanje studenata s radnim okruženjem aplikacije Final Cut Pro X (10.4), ali i osnovama 
montaže, primene video tranzicija, video efekta i titlova. Final Cut Pro X  (FCP X) je aplikacija kompanije Apple 
koja objedinjuje softvere za nelinearnu video montažu, u određenoj meri kompoziting i specijalne efekte. 
Namenjen je radu isključivo operativnom sistemu MacOS. Podržan je veliki broj digitalnih profesionalnih 
formata kao što su AVCHD, DV, HDV i DVCPRO HD... FCP X takođe podržava formate koji nisu za emitovanje 
(engl. nonbroadcast formats), već za strimovanje video sadržaja poput H.264 koji se koriste na Apple 
uređajima kao što su iPhone, iPad i sl.  

 

1. Pokrenite aplikaciju Final Cut Pro X.  

Po završetku otvaranja aplikacije otvoriće se radno okruženje same aplikacije. Pregledajte ga! 

 
Radno okruženje Final Cut Pro  aplikacije sastoji se od pet glavnih prozora: 

A. prozor omogućava izbor biblioteka (eng. Libraries), fotografija i zvuka (eng. Photos and Audio) i 
titlova i generičkih elemenata (eng. Titles and Generators). 

B. prozor je namenjen gledanju medijskih sadržaja (eng. Media Browser) koji su izabrani u prozoru 
A.  

A. i B. prozor se zajedno nazivaju pregledač (eng. Browser) 

C. prozor namenjen je gledanju medijskih sadržaja (eng. Viewer) iz svih ostalih prozora. 
D. prozor namenjen je svim podešavanjima (eng. Inspector) na medijskim sadržajima na kojima se 

radi. 
E. prozor namenjen je montaži a/v klipova. 

Na početku radno okruženje nema sve otvorene prozore, sada ćemo otvoriti još neke. 

2. 2xLK miša prvi vrhu prozora Inspector. 

Inspector je sada otvoren u punoj visini radnog okruženja, što će za brojne efekte biti neophodno.  
Iznad Inspector prozora, nalazi se meni (tri dugmeta) koja uključuju i isključuju delove radnog okruženja: 

                   A.           B.           C.                         D. 

 
 

A. dugme uključuje/isključuje prozor Browser. 



B. dugme uključuje/isključuje prozor Timeline. 
C. dugme uključuje/isključuje prozor Inspector. 
D. dugme otvara meni za deljenje (eng. Share) a/v materijala. 

 
3. Uključite i isključite dugmad pri vrhu prozora Inspector. 

Ukoliko želite da prilagodite radno okruženje. Povlačenjem ivica prozora moguće je povećati (i smanjiti) 
pojedine prozore. 

4.  Promenite veličinu prozora u radnom okruženju. 

FCP X omogućava čuvanje novih radnih okruženja. 

5. Window > Workspaces > Save Workspace as… > Proba. 

 
Sačuvano radno okruženje nalaziće se na vrhu podmenija Workspaces.  

6. Window > Workspaces > Default. 

Sada smo se vratili na početno radno okruženje. Sada ćemo obrisati radno okruženje Proba. 

7. Window > Workspaces > Open Workspace Folder in Finder. 
8. U Finder prozoru obrišite radno okruženje Proba.fcpworkspace iz foldera Workspaces i iz kante za 

otpatke i vratite se u FCP X. 

U meni liniji prozora Timeline, s desne strane nalaze se pregledači video tranzicija i video efekata. 

9. LK miša na dugme Transition Browser otvara pregledač predefinisanih video tranzicija, a LK miša na 
dugme Effects Browser otvara pregledač predefinisanih video efekata. 



  
Da bismo nastavili sa predledom radnog okruženja neophodno je uvesti neke a/v klipove u FCP X, ali pre 
toga, podesićemo radnu biblioteku (Library)1. 

10. File > New > Library… 
11. U prozoru Finder-a izaberite Movies folder, napravite svoj radni folder (npr. Marko Petrovic 

AVT1018). Biblioteku nazovite po vašem imenu. Pritisnite Save. 

Postoji više načina za uvoženje a/v i grafičkih klipova:  

A. File > Import > Media… ili ⌘	+ I.	 
B. Klikom na dugme Import Media u prozoru Media Browser. 

 
12. Pritisnite File > Import > Media…  

Pred vama je Media Import prozor koji služi za uvoženje a/v klipova u FCP X. U zavisnosti od željenog načina 
radia, Media Browser može se koristiti već od faze apsorpcije video materijala (eng. Ingest) ili sa već 
snimljenim fajlovima koji se nalaze na disku ili serveru. 
 
U levom delu prozora prikazuju se diskovi, serveri i memorijske kartice ili uređaji koji su povezani za računar 
(kamere, fotoaparati…). U centralnom delu (gore) nalazi se prozor za pregled materijala sa ikonicama za 
puštanje ili prebacivanje na naredni/prethodni a/v klip unutar prozora. U centralnom delu (dole) nalazi 
prilagođena verzija Finder prozora.  

                                                        
1 Library predstavlja biblioteku za čuvanje a/v klipova koji se koriste u FCP X. Library predstavlja prostor (Finder ga vidi kao 
„Package“) u kome će svi a/v klipovi (ako uključite opciju Copy to library pri uvoženju fajlova) event-ovi i projekti biti smeštani 
prilikom rada u FCP X.  FCP X nema klasičan način čuvanja projekata zbog čega je važno paziti šta se snima u koju biblioteku i koji 
klipovi se nalaze u kom event-u. 



 
Desni deo prozora (dato na slici desno) predstavlja novost u odnosu 
na uobičajni način korišćenja softvera za nelinearnu montažu pa 
ćemo mu se detaljno posvetiti. 
Radio dugme Add to existing event sa padajućim menijem 
omogućava uvoženje a/v klipova u već postojeći event 
(predefinisano svaki event se zove po datumu uvoženja a/v klipova). 
Radio dugme Create new event in omogućava pravljenje novog 
event-a i njegovo smeštanje u okviru određene biblioteke (Library). 
Polje Event name omogućava dodeljivanje željenog imena event-u.  
U odeljku Files nalazi se opcija koja u najvećoj meri razlikuje sistem 
menadžmenta a/v klipova u FCP X u odnosu na Premiere Pro CC. 
Ovde postoje dve opcije za uvoženje a/v klipova: Copy to library ili 
Leave files in place. Ukoliko izaberete prvu opciju svi fajlovi će biti 
kopirani unutar vaše biblioteke čak i ako se nalaze na računarskom 
disku (ova opcija pravi duplikate vaših fajlova ukoliko ih već imate 
smeštene negde na računaru!). Opcija Leave files in place 
omogućava rad koji u najvećoj meri podseća na rad u aplikaciji 
Premiere Pro, jer će program u ovom slučaju samo referisati na 
originalne fajlove na disku računara. 
Prilikom uvoženja fajlova na vežbama uvek proverite da li je 
uključena opcija Leave files in place! Opciju Copy to library nećemo 
koristiti na vežbama. 
Opcija Keywords omogućava lakšu pretragu a/v klipova u FCP X 
uzimajući u obzir eventulane tag-ove iz Finder-a i foldera koji u sebi 
nose dodatne metapodatke o klipu. 
Opcija Audio Roles omogućava da se audio klipovi ili audio u a/v 
klipovima postavlja u panelu Timeline prema ulogama koje određeni 
zvuk ima u a/v sadržaju, pa FCP X razlikuje: dijalog, muziku, efekte. 
Uključivanjem ove opcije FCP X pokušava da na osnovu analize zvuka 
i mesta odakle je fajl uvezen u projekat odredi koju ulogu treba da 
dodeli audio komponenti a/v klipa ili samostalnom audio klipu. 
Opcija Transcoding omogućava pravljenje drugačijih fajlova (drugi 
kodek i/ili frejm rejt) putem Optimized media opcije ili ukupne 
veličine fajlova (definicija) putem Proxy media opcije. 
Opcija Analize and Fix omogućava automatsko analiziranje audio i 
video sadržaja unutar klipova u cilju ispravki tehničkih nedostataka 
(balans bele, greške u zvuku, uklanjanja praznih audio kanala iz a/v klipova) ili automatskog prepoznavanja 
lica u klipovima radi lakše pretrage po ključnim rečima, odnosno određivanja filmskog plana u kome su 
subjekti snimani. 

13. Izaberite Create new event in, iz padajućeg menija izaberite biblioteku koja nosi vaše ime, dodelite 
ime event-u: Dokumentarni film.  

14. Files > Leave files in place. 
15. Isključite sve opcije u odeljcima Keywords, Transcoding, Analyze and Fix. 
16. U levom delu prozora izaberite Desktop, u centralnom delu dole 2xLK miša na folder Banka 11 > 

Video. 
17. Obeležite sve klipove, pritisnite dugme Import All.  

Svi a/v klipovi i učitani su prozor Browser. Sada možemo videti još neke opcije. 
 
 
 



U gornjem desnom uglu prozora Browser nalaze se: 
     A.                  B.     C.     D. 
  
 

E.   

 

A. meni omogućuje prikaz svih klipova (eng. All Clips), uklanjanje klipova koji su označeni kao 
nepotrebni (eng. Hide Rejected), prikaz klipova koji nemaju označen rejting ili ključne reči (eng. 
No rating or Keywords), prikaz klipova označenih kao omiljeni (eng. Favorites), prikaz nepotrebnih 
klipova (eng. Rejected), prikaz klipova koji nisu upotrebljeni u projektu (eng. Unused). 

B. dugme uključuje jedan od dva načina prikaza klipova kao filmske trake (eng. filmstrip) ili niza 
fajlova sa prikazom iznad (eng. list). 

C. dugme uključuje dodatni prozor (Clip Appereance and Filtering Menu),  koji se odnosi na način 
prikaza klipova u prozoru Browser. 

D. dugme uključuje konekstno polje za pretragu uveženih klipova.  
E. dugme uključuje prozor za filtriranje pretrage.  

Objasnićemo opcije dodatnog prozora (C.): 
 
 

                                  F.    
                                  G.  

                                   

                                  H.  
                                  I. 
                                  J. 
                                  K.      

 

F. klizač određuje veličinu prikaza filmskih traka u prozoru Browser. 
G. klizač određuje koliki je korak (u sekundama) koji se prikazuje na filmskoj traci u prozoru Browser. 
H. meni omogućuje grupisanje klipova prema različitim kriterijumima 
I. meni omogućuje sortiranje klipova prema različitim kriterijumima 
J. opcija Waveforms omogućuje prikaz talasnog oblika zvuka pored vizuelnog prikaza klipova 
K. Continius Playback omogućava kontinuiranu reprodukciju tokom pregledanja klipova. 

Objasnićemo opcije dodatnog prozora (E.): 

 
U meniju levo nalazi se opcija za odabir klipova na koje će se odnositi filtriranje. 
U meniju desno nalazi se opcija za odabir načina filtriranja prema tekstu, vrsti klipova, ključnih reči, datuma 
itd. Pritiskom na dugme „+“ dodaje se novi red za filtriranje. Predefinisano je uključen jedan red koji se 
odnosi na filtriranje na osnovu teksta. U meniju prvog kriterijuma za filtriranje moguće je izabrati da li 
traženi klipovi uključuju (eng. includes), ne uključuju (eng. does not include), jesu (eng. is), ili nisu (eng. is 



not) u određenoj grupi ukucavanjem određenog teksta. Kada se izabere željeni filter pritisne se dugme 
„New Smart Collection“ koje će svrstati klipove prema željenom kriterijum, a što je moguće uključiti za 
pregledanje iz menija s leve strane prozora Browse.  

18. U prozoru Browser izaberite Clip Appereance and Filtering Menu, iz njega prvi klizač postavite na 
polovinu, a drugi skroz ulevo, zatim u drugom meniju izaberite sortiranje po imenu (eng. Name). 

19. Prevlačenjem miša (bez klika) preko filmskih traka vrši se pregled u glavnom prozoru (Viewer). 

Sada ćemo napraviti projekat2.  

20. Kliknite na dugme New Project u prozoru Timeline. 
21. U polje Project Name, upišite probni projekat.  
22. Iz menije In Event: izaberite Dokumentarni film. 
23. Starting Timecode ostavite vrednost 00:00:00:00 
24. Iz menija Video izaberite: 720p HD, 1280x720, 25p. 
25. Iz menija Rendering izaberite Apple ProRes 422. 
26. Iz menija Audio izaberite: Stereo, 48kHz. 

 
27. Pritisnite OK. 

Prozor Browser treba da izgleda slično kao na slici. 

 
28. LK miša na klip Biljne vasi u prozoru Browser. 
29. Prevucite klip u projekat (prozor Timeline). 
30. Pregledajte klip. 

                                                        
2 Kada bismo se prebacili na nazive i funkcije koje ima Premiere Pro CC, u poređenju s njim, projekat iz FCP X bi bila sekvenca 
u Premiere Pro, a event iz FCP X bi predstavljao projekat u Premiere Pro.  



Klipovi se u prozoru Timeline reprodukuju i zaustavljaju pritiskom na taster Space. Tasteri J, K i L imaju istu 
funkciju kao i u Premiere Pro CC. Takođe, pritiskom na tastere strelica levo ili strelica desno, prikaz se 
pomera za po jedan frejm napred odnosno nazad. 

31. Pomerite indikator vremena (eng. playhead) na 00:00:05:00. 
32. Postavite miša na početak klipa, umesto strelice, pojaviće se kontekstna alatka za skraćenje klipa. 

Skratite klip na za 5 sekundi, odnosno do mesta na kome ste postavili indikator vremena. 

 
Nakon skraćenja klipa nije ostao bilo kakav prazan prostor ispred klipa već se klip automatski povuka na 
početak projekta – ova opcija se naziva magnetic timeline.  

33. Postavite indikator vremena na 00:00:03:00. Skratite klip zdesna-nalevo do indikatora. 
34. U prozoru Browser obeležite klip Bumbar1. Nakon što obeležite klip, stanite na levu ivicu filmske 

trake i povucite žuti okvir sleva-nadesno dok ispod prozora Viewer ne bude ispisan tajmkod 
00:00:02:16 

Klip je moguće prevući na željeno mesto u projektu, ali postoje i dodatne opcije: 
                            A.      B.     C.      D. 

 
A. dugme omogućava vezivanje klipa za postojeći klip koji je na primarnoj traci3 (Connect 

selected clip to primary storyline skr. Connect), skraćenica na tastaturi Q. 
B. dugme omogućava umetanje klipa na primarnu traku na mestu gde se nalazi indikator 

vremena ili na sekunarnu traku ukoliko je na njoj obeležen klip (Insert selecte clip in the 
primary storyline or selected storyline, skr. Insert), skraćenica na tastaturi W. 

C. dugme omogućava dodavanje klipa na primarnu traku na mestu gde se nalazi indikator 
vremena ili na sekunarnu traku ukoliko je na njoj obeležen klip (Append the selected clip to 
the primary storyline or selected storyline, skr. Append), skraćenica na tastaturi E. 

D. dugme i padajući meni prepisuju postojeći klip na primarnoj traci na mestu gde se nalazi 
indikator vremena ili na sekundarnoj traci ukoliko je na njoj obeležen klip (Overwrite the 
primary storyline or selected storyline with the selected clip, skr. Overwrite), skraćenica na 
tastaturi D. Iz menija moguće je odabrati opciju koja će prepisivanje uraditi samo za video 
(Video only) ili samo za audio (Audio only) komponentu klipa. 

Sada ćemo probati ove opcije. 

35. Pritisnite taster E ili pritisnite dugme Append. 

Deo klipa Bumbar1, sada se nalazi iza klipa Biljne vasi. 
Prikaz u prozoru Timeline moguće je uvećati kombinacijom tastera ⌘	+ =, a smanjiti kombinacijom tastera 
⌘	+ -. 

                                                        
3 FCP X nema klasične kanale ili trake kao druge aplikacije za audio ili video već tzv. storyline, koji se deli na primarni (slično 
traci Video 1 u Premiere Pro CC) i sekundarne (slično traci Video 2 u Premiere Pro CC). Klipovi koji se postavljaju na primarnu 
traku (u nastavku teksta reč storyline biće prevođena kao traka) predstavljaju osnovu, može se reći master traku, dok 
sekundarne trake mogu da imaju više klipova koji se vertikalno kače za primarnu traku. 



36. Uveličajte prikaz prozora Timeline. Obeležite klip Bumbar 1 i prevucite ga ispred klipa Biljne vasi. 

Timeline u FCP X nije destruktivan. Klipovi su ovom radnjom praktično zamenili mesto, a da pri tome nije 
postojala opasnost da klip koji se premešta prepiše svoj sadržaj preko klipa koji je stajao u projektu.  

37. Postavite indikator vremena neposredno pred kraj klipa Bumbar 1.  
38. U prozoru Browser izaberite klip Gusenica 1. Pritisnite taster W na tastaturi ili pritisnite dugme 

Insert. 

Uz pomoć ovog dugmeta klip Bumbar je podeljen na dva dela, između koga je ubačen ceo klip Gusenica 1, 
klip Biljne vasi je dalje gurnut udesno. 

39. Postavite indicator vremena na početak klipa Gusenica 1. 
40. U prozoru Browser izaberite klip Komarac 1. Pritisnite taster D na tastaturi ili pritisnite dugme 

Overwrite. 

Uz pomoć ovog dugmeta klip Komarac 1 je obrisao najveći deo klipa Gusenica 1. 

41. Edit > Undo. 

Ponovićemo istu komandu sa dužim klipom. 

42. U prozoru Browser izaberite klip Komarac 2 i pritisnite taster D na tastaturi. 

Uz pomoć ovog dugmeta klip Komarac 2 je obrisao sve klipove koji su se nalazili udesno od indikatora 
vremena jer je trajanje klipa bilo duže od svih klipova (zajedno) koji su bili na primarnoj traci. 

 
 
 
Zbog osobina koje ima prozor Timeline spisak alata za manipulaciju klipovima je znatno kraći nego u 
aplikaciji Premiere Pro CC: 
 
 
 
             A. 
                                                  B. 
                                C. 
             D. 
             E. 

                       F. 
            G. 

 
 

A. Select alatka, omogućava selekciju, pomeranje i skraćivanje klipova, skraćenica na tastaturi 
A. 



B. Trim alatka, omogućava menjanje mesta reza između dva susedna klipa, skraćenica na 
tastutri T. 

C. Position alatka, omogućava pomeranje klipova koje ignoriše magnetska svojstva prozora 
Timeline, čime se se stvara procep (eng. gap) između klipova, skraćenica na tastaturi P. 

D. Range selection, obeležavava deo klipa ili više klipova za deljenje ili drugu manipulaciju u 
prozoru Timeline, skraćenica na tastaturi R. 

E. Blade, seče klip na dva dela na mestu klika, ukoliko je blizu indikatora vremena, automatski 
pravi rez na tom mestu, skraćenica na tastaturi B. 

F. Zoom, uveličva prikaz u prozoru Timeline, uz kombinaciju s tasterom smanjuje prikaz, 
skraćenica na tastaturi Z. 

G. Hand, omogućava bezbedno kretanje u prozoru Timeline bez mogućnosti slučajnog 
obeležavanja ili pomeranja klipova, skraćenica na tastaturi H. 
 

43. Probajte sve prethodno opisane alatke u prozoru Timeline. 
44. Obeležite klip Komarac 2 u prozoru Timeline i pritisnite taster Backspace. 
45. Iz prozora Browser ubacite u projekat klip Stenica 6 (smrdibuba). 
46. Na vremenu 00:00:02:00 povucite iz prozora Browser klip Stenica 8 (smrdibuba) i postavite ga iznad 

klipova u projektu. 

Na ovaj način klip smo postavili u sekundarnu traku. 

47. Obeležite klip Stenica 6 (smrdibuba) na primarnoj traci i prevucite ga ispred klipa Bumbar 1. 

Klipovi su povezani jer je klip Stenica 8 (smrdibuba) zakačen za klip Stenica 6 (smrdibuba). 

 
Ukoliko želite da klip koji je na primarnoj traci, a na koga je u sekundarnoj zakačen drugi klip, otkačite i 
povučete na neko drugo mesto u projektu, a da pri tome sekundarni klip ne promeni mesto, potrebno je uz 
izabranu Selection alatku i povlačenje klipa držati taster na tastaturi ~ ili ‘ (u zavisnosti od rasporeda slova 
tastature). 
U prozoru Timeline s desne strane postoje i sledeće opcije: 

                                          A.    B.            C.       D.        E.      F.  
 

 
                               
         G. 
 
        H. 
 
         I.  
 
                       

       J.    
 
 
 
 
 



A. dugme uključuje/isključuje mogućnost reprodukcije videa i audia na filmskim trakama 
prevlačenjem kursora miša preko prikaza (Video and Audio Skimming), skraćenica na 
tastaturi S. 

B. dugme uključuje/isključuje mogućnost reprodukcije audia na filmskim trakama prevlačenjem 
kursora miša preko prikaza (Audio Skimming), skraćenica na tastaturi Shift+S 

C. dugme uključuje/isključuje automatsko lepljenje u prozoru Timeline (Snapping), skraćenica 
na tastaturi N 

D. meni otvara opcije za prikaz sadržaja u prozoru Timeline. 
E. dugme otvara/zatvara prozor za pregledač efekata 
F. dugme otvara/zatvara prozor za pregledač tranzicija 
G. klizač omogućava promenu veličine prikaza u prozoru Timeline (po širini) 
H. meni omogućava izbor načina prikaza klipova u prozoru Timeline 
I. klizač omogućava promenu veličine prikaza u prozoru Timeline (po visini) 
J. meni Show omogućava izbor podataka koji će biti prikazani u prozoru Timeline 

(predefinisano su uključeni nazivi klipova). 
 

48. File > Import > Media… 
49. Iz foldera Banka 11 > Audio obelžite klip Audio11_1-Johanes Brams Madjarska igra br. 6 D-dur. 
50. U prozoru Inspector klip je obeležen kao dijaloški što je greška. 
51. Klikom na meni na prikazu talasnog oblika zvuka izaberite ocpiju Music. 

 
52. Uvezite audio klip iz prozora Browser u projekat ispod početka prvog video klipa. 

Zasebni audio klipovi se ponašaju kao sekundarne trake i kače se za određeni video klip. Brisanjem video 
klipa za koji je nakačen audio klip, biće obrisana oba klipa. 

 
53. Skratite povlačenjem leve ivice audio klipa, deo u kome nema zvuka i obratite pažnju kako se kip 

ponaša u odnosu na primarnu traku. 

Nakon skraćenja, klip je ostao zakačen za primarnu traku ali na sam kraj klipa Bumbar 1. 



54. Povucite audio klip na početak projekta. 
55. U prozoru Timeline obeležite video klip Stenica 8 i skratite njegovo trajanje do kraja klipa Bumbar 1. 
56. Izaberite Position alatku i povucite klip Bumbar 1 udesno tako da postane vidljiv u primarnoj traci. 

FCP X je automatski generisao procep koji je obeležen kao sivi neimenovani klip u primarnoj traci. Ovaj klip 
se ponaša slično isto kao i drugi klipovi, moguće ga je skraćivati ili pomerati u prozoru Timeline. 

 
57. Obeležite klip Stenica 8 (smrdibuba) u sekundarnoj traci. 

U desnom delu radnog okruženja u prozoru Inspector, moguća je manipulacija i izmena ovog klipa. U vrhu 
prozora nalaze se opcije za različite poglede: 
                        A.     B.    C. 

 
A. (obeleženo) dugme uključuje Video Inspector prozor za podešavanja na video klipu (u slučaju 

da je u obeležen audio klip, umsto simbola filmske trake biće prikazan simbol zvučnika). 
B. dugme uključuje Color Inspector koji se koristi za korekciju boja na klipu. 
C. dugme uključuje Info Inspector koji prikazuje podatke i metapodatke o klipu. 

 
U vrhu prozora inspector stoji naziv obeleženog klipa, a u 
desnom uglu tajmkod prozora Timeline. 
Video Inspector prozor podeljen je u sledeće celine: 
Compositing, Transform, Crop, Distort, Stabilization, Rolling 
Shutter i Spatial Conform (uključivanje i isključivanje vidljivosti 
odeljaka je na opciji Show/Hide koja je u desnom uglu 
odeljaka). 
Compositing: Blend Mode meni omogućava izbor različitih 
blendi za spajanje klipova (kao Leyer-a u aplikaciji Photoshop 
CC); Opacity slajder omogućava izbor procenta neprovidnosti 
klipa. 
Transform: Position omogućava pomeranje klipa u okviru 
projekta po X i Y osama; Rotation točak omogućava rotaciju 
video klipa; Scale (All) klizač omogućava proporcionalnu 
promenu veličine; Anchor omogućava pomeranje ose rotacije 
klipa po X i Y osama. 
Crop: Type meni omogućava izbor tri vrste sečenja klipova: Trim 
seče klip sa svih strana za određeni broj piksela; Crop (kada se 
smanjuju vrednost) seče klip sa svih strana pri čemu pozicionira 
klip na sredinu ili (kada se povećavaju vrednosti) seče delove 
klipa i uveličava klip do maksimalne veličine; Ken Burns radi 
automatsko uveličavanje klipa tokom vremena što je korisno 
pri animiranju pokreta statičnih fotografija. 
Distort: omogućava postavljanje klipa u određenu perspektivu 
u četiri tačke prema X i Y osama. 
Stabilization: omogućva stabilizaciju snimaka. 
Rolling Shutter: ispravlja grešku prilikom snimanja ukoliko 
brzina zatvarača nije bila adekvatno podešena. 



Spatial Conform: omogućava brzo prilagođenje veličine klipa definiciji projekta, predefisana opcija u meniju 
je Fit koja sliku proporcionalno smanjuje/uveličava sliku do definicije projekta; Fill opcija proporcionalno 
smanjuje/uveličava sliku do definicije projekta sa mogućim opsecanjem „viškova“ čime se izbegava 
pojavljivanje crnih ivica oko slike; None opcija postavlja sliku u prirodnoj veličini bez obzira na izabranu 
definiciju projekta. 
Napravićemo zatamnjenje (eng. Fade to Black) korišćenjem ključnih slika. 

58. Postavite indikator vremena na početak procepa u prozoru Timeline. 
59. U prozoru Inspector > Compositing > Opacity, kliknite na dugme Add a keyframe, čime ćemo dodati 

prvu ključnu sliku. 

 
60. Postavite indikator vremena na kraj procepa u prozoru Timeline.  
61. U prozoru Inspector > Compositing > Opaciti, povucite klizač na 0.0% (čime će automatski biti dodat 

još jedna ključna slika. 

 
U prozoru Timeline, iznad svih traka pojavila se tačkasta linija koja označava da FCP X mora da izrenderuje 
prikaz kako bi sa potpunom tačnoššću mogao da reprodukuje svaki frejm. Da bi rendering otpočeo 
potrebno je na trenutak prekinuti s radom. Kada linija nestane, FCP X je završio render prikaza.  
Napomena: Svaki rad (čak i pomeranje strelice miša) u radnom okruženju prekida započeti render prikaza. 

62. Reprodukujte prikaz. 

Ključne slike u FCP X se ne prikazuju u prozoru Inspector, već direktno na klipu koji je animiran. 



 
63. DK miša na klip Stenica 8 (smrdibuba) u prozoru Timeline otvara kontekstni meni izaberite Show 

Video Animation. 

 
U zavisnosti od broja uključenih opcija u prozoru Inspector, iznad klipa će se pojaviti više traka za prikaz 
animacije ključnih slika.  

64. Kliknite na strelicu na desnoj strani trake Compositing: Opacity. 

Sada se jasnije mogu videti ključne slike koje su postavljene na klipu, njih je moguće promeniti 
povlačenjem ili dodati nove pomoću dugmeta Add Keyframe u prozoru Inspector. 

 
65. DK miša na klip Stenica 8 (smrdibuba) > Hide Video Animation ili kliknite na x u gornjem levom uglu. 

Sada ćemo dodati video efekat na isti klip. 

66. Iz prozora Effects > Looks, prevlačenjem miša preko filmske trake efekata (uz prikaz u glavnom 
prozoru) možete videti kako će efekat izgledati na klipu.  

67. Izaberite Cast efekat i prevucite ga na klip. 

Sačekajte da FCP X izrenderuje prikaz efekta na klipu. U prozoru Inspector pri vrhu pojavila su se 
podešavanja za efekat Cast.  

68. U prozoru Inspector > Cast > kliknite na prikaz plavičaste boje i izaberite neku nijansu žute. 
69. Iz prozora Browser izaberite klip Leptir 12 i stavite ga u projekat iza klipa Bumbar 1, zatim izaberite 

klip Maslacak 3 i stavite ga u projekat iza svih klipova. 
70. Izaberite Blade alat i prepolovite klipove Leptir 12 i Maslacak 3. 
71. Izbrišite drugi deo klipa Leptir 12. 
72. Izbrišite prvi deo klipa Maslacak 3. 



Sada ćemo dodati video tranziciju na mesto reza između ova dva klipa. 

73. Iz prozora Transitions > Dissolves, prevlačenjem miša preko filmske trake tranzicije (uz prikaz u 
glavnom prozoru) možete videti kako tranzicija izgleda na generičkim klipovima. 

74. Izaberite Crossdisolve efekat i prevucite ga na mesto reza. 
75. 2xLK miša na efekat u prozoru Timeline otvoriće poseban editor za efekte. 

 
76. Povlačenjem sivog klizača u strane, moguće je repozicionirati efekat i promeniti njegovo trajanje. 

U panelu Inspector umesto podešavanja za klipove, sada se nalaze podešavanja video tranzicije koje je 
moguće prilagoditi. 

 
77. Zatvorite editor video tranzicije 2xLK miša po sredini klizača.  

Sada ćemo napraviti novi projekat u okviru event-a Dokumentarni film. 
Napomena: FCP X automatski u kontinuitetu čuva projekat i sve izmene.  
Nakon otvaranja novog ili drugog projekta, opcijom Undo nije moguće vraćanje unazad  (kao ni nakon 
zatvaranja aplikacije).   

78. File > New > Project… > upišite ime Glavni projekat > OK. 

 
 



79. Potrebno je izmontirati kratki dokumentarni film o flori i fauni Velikog ratnog ostrva. Dozvoljeno je 
korišćenje svih prethodno uveženih klipova iz Banke 11. Trajanje filma treba da bude oko 3 minuta i 
45 sekundi.Za montažu klipa potrebno je uvesti i audio klip Audio12_3-Naracija_skraceno po kome 
će se montirati film (u naraciji je moguće dodatno razdvojiti rečenice pauzama). Tokom filma treba 
koristiti muziku Audio11_1-Johanes Brams Madjarska igra br. 6 D-dur koja predstavlja i optimalno 
trajanje filma (u prozoru Inspector muziku treba smanjiti na oko -12dB). 

Pre početka rada na filmu, napravićemo dva titla koja će biti potrebna. 

80. Pritisnite dugme u gornjem levom uglu prozora Browser > Show or Hide Titles and Generators 
Sidebar. 

 

81. Izaberite Fade titl i prevucite ga u projekat Glavni projekat. 

U zavisnosti od vrste titla u prozoru Inspector, pojaviće se nekoliko novih dugmadi na koja otvaraju panele 
za izmenu predefinisanog izgleda titla. 

82. U prozoru Inspector > Show Text Inspector (=). 
83. U polju Text upišite > VELIKO RATNO OSTRVO. Iz menija Basics, izaberite font po slobodnom izboru 

i veličinu slova. 



 
84. U vrhu prozora Inspector izaberite Show Title Inspector. 
85. Izaberite svetlo sivu boju iz palete; iz menija Out Size izaberite Line. 

 

86. Izaberite svetlo sivu boju iz palete; iz menija Out Size izaberite Line. 

Ovaj titl koristiće se na početku videa. Sada ćemo napraviti i odjavni titl koji treba postaviti na kraj 
dokumentarnog filma. 

87. Izaberite iz prozora Browse > Scrolling i prevucite u projekat. 
88. U prozoru Inspector > Show Text Inspector > izmenite tekst da odgovara podacima sa slike, koristite 

isti font i boju kao u uvodnom titlu. 
89. U prozoru Inspector > Show Title Inspector > Reduce Flicker > Progressive. 



U delu teksta montaža s leve strane upišite svoje ime i prezime i broj indeksa. Ukoliko je potrebno 
prilagodite veličinu slova i brzinu pomeranja (izmenom veličine klipa u prozoru Timeline). 

 

 


